The Industry Standard In Infrastructure Monitoring

GETIEPARY  Understanding The User Macros Component

Purpose

This document describes how to use the User Macros component in Nagios XI. The

component exposes the user and system macros available in Nagios Core to multiple areas of

Nagios Xl, allowing for more flexible configurations.

Target Audience

This document is intended for use by Nagios XI Administrators who want to take advantage of user and

system macros in Nagios XI.

What Is A Macro ?

One of the main features that make Nagios so flexible is the ability to use macros in object definitions. If you

are familiar with programming languages, a macro is just like a variable:

* Avalue is assigned to a macro
* The macro is used in object definitions

* |If you update the macro, all the object definitions use the updated value in the macro

There are two types of macros in Nagios Xl, user macros and system macros.

What Does The User Macros Component Do ?

The primary purpose of the User Macros component is to $ARGLS .
make the user and system macros available for use when $HOSTADDRESSS
$ARG2S $HOSTSTATES
using Configuration Wizards or when editing objects in Core STIMETS
. . SARG3S
Configuration Manager (CCM). SUSERL$
sARG4g | FUSER7S
$USERAS
An auto-complete list will appear when you start typing with a $ARGSS

$ (dollar) character, see the screenshot to the right. In the

example shown to the right, a combination of user and system macros is shown.
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The User Macros component allows you to edit the existing user macros and also add new macros. This

functionality is performed in CCM and will be explained in this documentation.

User Macros

User macros are macros that can be defined by the Nagios XI administrator. They are stored by default in the

resource.cfg file which is located in the /usr/local/nagios/etc/ directory.

The syntax to define a macro in this file is:

SUSERNnS=x

* n =anumber between 1-256 (you cannot have the same number defined more than once, the first

defined macro will always take precedence)

* x = the value of the macro, no space after the = character

The resource. cfg file will have default macros defined in it already such as
SUSER1S$=/usr/local/nagios/libexec and these should not be edited or removed without knowing the
full consequences - this can break the core processes from running checks and could be a real headache.
The SUSER1S$ macro is a great example of how a macro is used in a command definition, take a look at this

command definition:

SUSER1S$/check http -H SHOSTADDRESSS

Instead of typing /usr/local/nagios/libexec all you need to type is SUSER1S in the command

definition.

The maximum number of macros by default is 256. You can change this through configuration if you need

more macros than the default (Note: the max number is a Nagios Core setting).
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A feature of the User Macros component is the ability to update the resource. cfg file from within CCM,

instead of having to edit the file from a terminal session, which will be explained in this documentation.

System Macros

System macros are macros that cannot be defined by the Nagios XI administrator, their values are inherited

from object definitions and can also be dynamic. Some examples are:

* SHOSTADDRESSS = The value of the address directive in a host definition
* SARGL1S = The value of argument #1 in a host or service definition

* SHOSTSTATES = The current state of the HOST object, this dynamic macro is commonly used in a

notification command

These macros are useful in a number of ways and are explained in detail here:

https://assets.nagios.com/downloads/nagioscore/docs/nagioscore/4/en/macrolist.html

A feature of the User Macros component is the ability to define which of these system macros will be made

available in areas like CCM and Configuration Wizards, which will be explained in this documentation.
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Configuring User Macros Component

Login to Nagios X| and navigate to Admin > System Extensions > Manage Components.

Home Views Dashboards Reports Configure Tools Help Admin e & nagiosadmin (& Logout
» System Information Scheduled Backups @&
» Users Provides the ability to schedule full Nagios XI backups. Core - 1.1.3

A System Config ¥ 1.1.3 09/15/2016 & Nagios Enterprises, LLC

» Monitoring Config Scheduled Reporting @
Adds scheduled reporting capability to Nagios XI. Core - 2.2.0
% 2.2.0 f#06/22/2016 & Nagios Enterprises, LLC

» Check Transfers

w System Extensions

& Manage Components, System Profile

# Manage contig Wizards This component creates a system profile menu in the Admin panel which can be used for troubleshooting purposes. Core = 1.3.1
0O Manage Dashlets % 1.3.1 [405/25/2016 & Nagios Enterprises, LLC

s Manage Plugins

Manage Graph Templates User Macros

Manage MIBs

B Customn Includes Manage user and system macros. Core

% 1.0.1 & Nagios Enterprises, LLC

. System Backups

Click the Edit Settings icon to configure the User Macros component, which will display the settings available

for the component as follows:

User Macros (7]

Detect, create, display and define system and user macros in Nagios XI.

This component will detect input of '$USERNS' user defined macros where 'n' is @ number between 1 and 256. This number is defined in Nagios Core as
MAX_USER_MACROS. It will also give a user a list of commonly used System Macros in the appropriate inputs. The system marcos are displayed using
autocomplete and the full list of available macros are defined in the System Macros tab.

Note: To manually enable detection fucnticnality on a page inside Magios XI or a custom compenent/tool you can add the class "usermacro-detection” to an HTML input.
% User Macro Control (CCM)
To view the macro files go the the User Macro section in the CCM by clicking this link.
Component Settings
These are the general settings for this component.
[[] Disable Companent

@ Redact Displayed Values (Enabled by Default)

This option will redact the USER macro values from being displayed to protect sensitive data for ALL users. With this opticn enabled you will still be able to add

undefined macros when they are detected. This will override the Non-Admin user setting.

Redact Values for Non-Admin Users

This option will r the USER macr

Apply Settings Cancel
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Disable Component:

This will turn off all detection of macros and the User Macro link in the CCM will not be available. This option
is specifically useful if you need to vet the component or have security concerns with the content of your

resources file where User macros are stored.

Redact Values:

User Macros often contain sensitive data such as passwords or tokens. They are also useful for using
restricted characters that are normally not allowed for use in certain commands (example: Nagios Core
interpreting a '!' character in a command). Since the information they hold can be sensitive, there are two

options for obscuring the values of the macros:

Redact Displayed Values:

This will redact USER macro values from being displayed anywhere. Here is an example:

$ARG1S | $USERESS s SUSERBG=""***

When you hover the mouse over the $ box a message box will display the value with asterisk's.

When Redact Displayed Values is enabled, you can create a new User macro while using the
detection in CCM and in Configuration wizards (explained in detail further on in this document).

However you will not be able to directly edit the User macros via CCM > Tools > User Macros.

In a fresh Nagios Xl install this will be turned on by default (enabled). If you turn off (disable) this

option all users will be able to see the macro values, for example:

$ARG1$ | SUSERB8S S ER&%=secret
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Redact Displayed values for Non-Admin Users:

This feature works exactly like the default redact function, but is specifically designed to always
show macro values to Admin level users and hide values from all non-admin users. This option can

only be enabled when the Redact Displayed Values option is disabled.

Here is an example of what an Admin user will see:

$ARGLS  $USERBS QB $USERB$=secret

Here is an example on what a NON-Admin user will see:

w Configuration Wizard: Windows Server -Step2 &

This should be considered when giving admin rights to users since those users will be able to see
all user macro values. This is similar to a user who has login access to the Nagios X| machine

since they could just read the resource. cfg file from the command line.

Edit User Macros

Login to Nagios Xl and navigate to Configure > Core Config Manager > Tools > User Macros.

Na g1 oS’ Home Views Dashboards Reports Tools Help Admin Q @ &nagiosadmin  © Logout =

CLI1 Core Config Manager

A Quick Tools

User Macros Component

Click here to configure the User Macro component %
» Monitoring

Component Settings: Component Enabled B Redact Displayed Values
A Alerting

4 Templates User Macros System Macros

A Commands

You can view and edit the assigned User Macros for your system here.

» Advanced
Note: If you edit this file it will overwrite the original content so you will not be able to undo any changes. If Redact Displayed Values is enabled you will not be able to edit the file.
w Tools
[ Stati onfig Editor fusr/flocal /nagios/etc/resource.cfg @
@ Escaﬁa Ton Wizard # Path to the plugins

2 Bulk Modifications Tool $USER1$=/usr/local/nagios/libexec

¥ Bulk Renaming Tool # Path to event handlers
& Import Config Files #$USER2$=/usr/local/nagios/libexec/eventhandlers

I Config File Management # Port for NSClient++
$USER7$=12480
# Password for NSClient++
A CCM Admin $USERB$=secret

Update
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The User Macros tab is the default tab selected. The User Macros section will appear differently depending
on how the User Macros component is configured.
Redact Displayed Values option is Enabled:
All of the values will be redacted and will appear with *****
You cannot edit existing values or add new values
The Update button is NOT displayed

Redact Displayed Values option is Disabled:
All of the values will be shown
You can edit existing values and add new values
The Update button is displayed
The screenshot on the previous page is an example of this.
Updating an existing macro or adding a new macro is as easy as adding a new line. For example:
SUSER10S$=!ts@S3cr3t
Click the Update button once you've made the changes.

Please refer to the User Macros section of this document for the correct syntax.

After making changes, Nagios Core will need to be restarted so that the updated values are loaded from the

resource.cfqg file. This can be done via CCM > Tools > Config File Management > Restart Nagios Core.
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System Macros

Login to Nagios X| and navigate to Configure > Core Config Manager > Tools > User Macros and then

click the System Macros tab.

Naglosl Home Views Dashboards Reports Tools Help Admin Q @ &nagiosadmin G Logout =

CLI) core Config Manager

# Quick Tools

# Configukation Wizards

User Macros Component

Click here to configure the User Macro component -2
A Monitoring

Component Settings: Compaonent Enabled B Redact Displayed Values
~ Alerting

» Templates User Macros System Macros

# Commands

Here you can add and remove System Macros that will be displayed as a selection option when a macro is detected.

# Advanced For general information about usage and which macros are supported check the Nagios Core documentation here. Double click to add and remove or select multiple and click the
+ Tools add/remove buttons.
[ Static Config Editor
— Active Detected System Macros
@ Escalation Wizard Host $HOSTADDRESSS
- . R
22 Bulk Mﬂdlﬁc...atluns Tool SHOSTNAMES $HOSTSTATES
% Bulk Renaming Tool $HOSTDISPLAYNAMES $TIMETS
& Import Config Files SHOSTALIASS
I Config File Management $HOSTADDRESS$ n
$HOSTSTATES
» CCM Admin $HOSTSTATEIDS
$LASTHOSTSTATES n
$LASTHOSTSTATEIDS
$HOSTSTATETYPES
$HOSTATTEMPTS
$MAXHOSTATTEMPTSS

Update

The purpose of the System Macros tab is to be able to select specific macros that you would like to be

displayed when the auto-complete list appears.

In the above screenshot you can see that three macros

$ARGLS$

were added to the Active Detected System Macros. oHOSTADDRESSS
In the screenshot to the right you can see that these PRES | gHostsTares
three macros are now available in the auto-complete list. e zzquZ:;

It's important to note that adding system macros to the $ARGAS zazz;z
Active Detected System Macros list is purely to make SARGSS

it easy to select a system macro from the auto-complete
list. All system macros will work in any configuration area

of Nagios Xl regardless if they are in this list or not.
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Creating New User Macros On The Fly

In the Edit User Macros section of this document you were shown how to add a new macro. Another feature
of the User Macros component is the ability to create a new User macro when you are in the middle of

running a configuration wizard OR editing an object in CCM. Here's how it works when you are in CCM.

First you start off by typing $U to make the auto- SARG1S
complete list appear. You can see in the screenshot to $USER1S
$ARG2S
the right that SUSER1S, SUSER7S$ and SUSER8S $USERT$
. $USERBS
already exist. $ARG3S

This example is going to add SUSER11$ as it does not exist.

Simply finish typing the name of the user Macro @
$ARGLS = $USER11%|
and as soon as you type the closing $ a blue $

button will appear to the right.

When you hover your mouse over the blue $ button a message window $

Undefined user macro detec
will appear informing you that the macro is undefined and to click it to set

a value.

Click the blue $ button and the Create New User Macro window will appear (see the following page).
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x
Type a value in the field at the bottom of the Create New User Macro
window and then click the Save Macro Jusr/local/nagios/ et/ resource.cfg ©
button. # Path to the plugins

SUSER1G=**%*=*

# Path to event handlers
#EUSER2§=**%%%

# Port for NSClient++
SUSERT§=****+

You will receive a success message once fssuord for NSCliente+

the new macro has been added.

Click the Close button when done.

New Macro  3$USER11§ ESup3r53cr3t ; Close

NOTE: The new macro will not be active until Nagios Core is restarted. This will occur when you Apply

Configuration OR you finish a Configuration Wizard.

The ability to add new user macros will be available as long as the User Macros component is enabled, see

the Configuring User Macros Component section for more information on this.
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Special Characters

User macros are a great way to use complicated passwords with special characters in them. Special
characters are a group of characters that carry out special instructions, like the dollar sign $ which does
expansion in bash. If you tried to use a $ in a password argument at the command line you will see it throw an

unexpected error.
In Nagios Configurations an exclamation mark ! Is used as an argument separator. If you used this in a
password then the password will be split and it will change the amount of arguments being presented to the

monitoring engine.

The following KB article explains special characters in more detail and should be taken into consideration with

user macros.

https://support.nagios.com/kb/article.php?id=580

Finishing Up
This completes the documentation on understanding the User Macros component in Nagios XI.

If you have additional questions or other support related questions, please visit us at our Nagios Support

Forums:

https://support.nagios.com/forum

The Nagios Support Knowledgebase is also a great support resource:

https://support.nagios.com/kb
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