How To Use The Nagios Xl 2024 User Macros

Component

Purpose

This document describes how to use The Nagios XI User Macros Component.

What is a Macro?

One of the main features that make Nagios so flexible is the ability to use macros in object
definitions. If you are familiar with programming languages, a macro is just like a variable:

e Avalue is assigned to a macro

e The macro is used in object definitions

e If you update the macro, all the object definitions use the updated value in the macro
There are two types of macros in Nagios XI, user macros and system macros.

What Does The User Macros Component Do?

$HOSTALIASS
$HOSTDISPLAYNAMES
$HOSTMAMES
$SERVICEDESCE
$SERVICEDISPLAYNAMES
$SERVICESTATES
SUSERI$

$USERTE

$USERS$

The primary purpose of the User Macros component is to make the user and system macros
available for use when using Configuration Wizards or when editing objects in Configuration
Manager.

An auto-complete list will appear when you start typing with a $ (dollar) character, see the screenshot
to the right. In the example shown to the right, a combination of user and system macros is shown.

The User Macros component allows you to edit the existing user macros and add new macros. This
functionality is performed in Core Configuration Manager and will be explained in this
documentation.
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User Macros

User macros are macros that can be defined by the Nagios XI administrator. They are stored by
default in the resource.cfgfile, located in the /usr/local/nagios/etc/ directory.

The syntax to define a macro in this file is:
SUSERNS=x
e n =anumber between 1-256 (you cannot have the same number defined more than once; the
first defined macro will always take precedence)
e x =the value of the macro, no space after the = character

The resource.cfg file will have default macros defined in it already such as
SUSER1S8S=/usr/local/nagios/libexec and these should not be edited or removed without
knowing the full consequences; this can break the core processes from running checks and could be
a real headache.

The SUSER1S macro is a great example of how a macro is used in a command definition, look at this
command definition:

SUSER1$/check_http -H SHOSTADDRESSS
Instead of typing /usr/local/nagios/libexec all you need to type is SUSER1S in the command
definition.

The maximum number of macros by default is 256. You can change this through configuration if you
need more macros than the default (Note: the max number is a Nagios Core setting).

A feature of the User Macros component is the ability to update the resource.cfg file from within
Configuration Manager, instead of having to edit the file from a terminal session, which will be
explained in this documentation.

System Macros

System macros are macros that cannot be defined by the Nagios XI administrator, their values are
inherited from object definitions and can also be dynamic. Some examples are:

e SHOSTADDRESSS = The value of the address directive in a host definition
e SARG1S = The value of argument #1 in a host or service definition

e SHOSTSTATES = The current state of the HOST object, this dynamic macro is commonly used
in a notification command
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These macros are useful in many ways and are explained in detail in this article.

A feature of the User Macros component is the ability to define which of these system macros will be
made available in areas like Configuration Manager and Configuration Wizards, which will be
explained in this documentation.

Configuring User Macros Component

1. Login to Nagios Xl and navigate to Admin > System Extensions > Manage Components.

Scheduled Reporting 8

Adds scheduled reporting capability to Nagios X1

220 2 Nagios Enterprises, LLC

System Profile

This component creates a system profile menu in the Admin panel which can be used for troubleshooting purposes.

210 X2 Nagios Enterprises, LLC

User Macros

Manage user and system macros.

120 2 Nagios Enterprises, LLC
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Click the Edit Settings icon to configure the User Macros component, which will display the
settings available for the component as follows:

User Macros

This component will detect input of "$USERN$' user defined macros where'n'is a number between 1 and 266. This number i defined in Nagios Core as MAX_USER_MACROS. It will also give a user a list of commonly
uged System Macros in the appropriate inputs. The system marcos are displayed using autocomplete and the full list of available macros are defined in the System Macros tab.

Note: To manually enable detection fucntionality on a page inside Nagios X| or a custom component/tool you can add the class "usermacro-detection” to an HTML input.

§

To view the macro files go the the User Macro section in the CCM by clicking this link.

Component Settings

These are the general settings for this component.

Disable Component

Redact Displayed Values (Enabled by Default)
This option will redact the USER macro values from being displayed to protect sensitive data for ALL users. With this option enabled you will still be able to

add undefined macros when they are detected. This will override the Non-Admin user setting.

Redact Values for Non-Admin Users
This option will redact the USER macro values from being displayed to all but Administrator level users.

Disable Component:

This will turn off all detection of macros and the User Macro link in the Configuration Manager will
not be available. This option is specifically useful if you need to vet the component or have security
concerns with the content of your resources file where User macros are stored.
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Redact Values:

User Macros often contains sensitive data such as passwords or tokens. They are also useful for
using restricted characters that are normally not allowed for use in certain commands (example:
Nagios Core interpreting a ' character in a command). Since the information they hold can be
sensitive, there are two options for obscuring the values of the macros:

Redact Displayed Values:

This will redact USER macro values from being displayed anywhere. Here is an example:

$ARG1S $USER1$ SUSER1§=>****

When you hover the mouse over the $ box a message box will display the value with asterisks.

When Redact Displayed Values is enabled, you can create a new User macro while using the detection
in Configuration Manager and in Configuration wizards (explained in detail further on in this document).
However, you will not be able to directly edit the User macros via CCM > Tools > User Macros.

In a fresh Nagios Xl installation this will be turned on by default (enabled). If you turn off (disable)
this option, all users will be able to see the macro values, for example:

$ARGI$ $USERS% $USERS8%=secret

Redact Displayed values for Non-Admin Users:

This feature works exactly like the default redact function but is specifically designed to always show
macro values to Admin level users and hide values from all non-admin users. This option can only be
enabled when the Redact Displayed Values option is disabled.

Here is an example of what the Admin user will see:

$USER8% $USER8%=secret
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Here is an example on what a NON-Admin user will see:

$ARGI$  SUSERIS$ SUSER1$=""*

This should be considered when giving admin rights to users since those users will be able to see all
user macro values. This would be like a user who has login access to the Nagios XI machine, since
they could just read the resource.cfg file from the command line.

Edit User Macros

1. Login to Nagios XI and navigate to Configure > Core Config Manager > Tools > User Macros.

User Macros Component

Click here to configure the User Macro component #%

Component Component [J Redact Displayed Redact Values for Non-
Settings: Enabled Values Admins

User Macros System Macros

You can view and edit the assigned User Macros for your system here. If you make changes to the resource.cfg file
from anywhere you must to restart Nagios Core for the new macros to be utilized.

Note: If you edit this file it will overwrite the original content so you will not be able to undo any changes. If Redact
Displayed Values Is enabled you will not be able to edit the file.

Jusr/local/nagilos fetc/resource.cfg

# Path to the plugins
$USER1$=/usr/local/nagios/libexec

# Path to event handlers
#$USER2%=/usr/local/nagios/libexec/eventhandlers

# Port for NSClient++
$USER7$-12489

# Password for NSClient++
$USERB%=secret

2 Restart Nagios Core
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2. The User Macros tab is the default tab selected. The User Macros section will appear
differently depending on how the User Macros component is configured.

a. Redact Displayed Values option is Enabled:
i. All values will be redacted and will appear with *****
ii. You cannot edit existing values or add new values
iii. The Update button is NOT displayed
b. Redact Displayed Values option is Disabled:
i. Allvalues will be shown
ii. You can edit existing values and add new values
iii. The Update button is displayed
iv. The screenshot above is an example of this.
Updating an existing macro or adding a new macro is as easy as adding a new line. For
example:

SUSER108=!ts@S3cr3t

Click the Update button once you've made the changes.
3. Please refer to the User Macros section of this document for the correct syntax.

4. After making changes, Nagios Core will need to be restarted so that the updated values are
loaded from the resource.cfg file. This can be done via CCM > Tools > Config File
Management > Restart Nagios Core.
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System Macros

Login to Nagios Xl and navigate to Configure > Core Config Manager > Tools > User Macros and then
click the System Macros tab.

Click here to configure the User Macro component ¢
Component Component D Redact Displayed Redact Values for Non-
Settings: Enabled Values Admins

User Macros System Macros

Here you can add and remave System Macros that will be displayed as a selection option when a macro is detected.

For general information about usage and which macros are supported check the Nagios Core documentation . Double click to add and remove or select multiple and click the add/remove
buttons.

Active Detected System Macros

Host
$HOSTNAMES

$HOSTNAMES

$HOSTDISPLAYNAMES $HOSTDISPLAYNAMES
LA $HOSTALIASS
$HOSTADDRESS$

$SERVICEDESCS
$HOSTSTATES

$HOSTSTATEIDS $SERVICEDISPLAYNAMES
(BRI A $SERVICESTATES
$LASTHOSTSTATEIDS

$HOSTSTATETYPES

$HOSTATTEMPTS

$MAXHOSTATTEMPTSS

$HOSTEVENTIDS

$LASTHOSTEVENTIDS

$HOSTPROBLEMIDS

$LASTHOSTPROBLEMID$

The purpose of the System Macros tab is to be able to select specific macros that you would like to
be displayed when the auto-complete list appears.

In this screenshot you can see that six macros were added to the Active Detected System Macros.
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In this screenshot you can see that these three macros are now available in the auto-complete list.

$ARGI$

$HOSTALIASS
$ARG2$ | $HOSTDISPLAYNAMES
$HOSTNAMES
$ARG3% | $SERVICEDESCS
$SERVICEDISPLAYNAMES
$ARGAS $SERVICESTATES
SUSERS

$ARG5% SUSERTS
$SUSERSS

It's important to note that adding system macros to the Active Detected System Macros list is purely
to make it easy to select a system macro from the auto-complete list. All system macros will work in
any configuration area of Nagios Xl whether they are included in this list or not.

Creating New User Macros On The Fly

In the Edit User Macros section of this document, you were shown how to add a new macro. Another
feature of the User Macros component is the ability to create a new User macro when you are in the
middle of running a configuration wizard OR editing an object in CCM. Here is how it works when you
are the Configuration Manager.

First you start off by typing SU to make the auto-complete list appear. You can see in the screenshot
to the right that SUSER1S, SUSER7S and SUSERS8S already exist.
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This example is going to add SUSER11S as it does not exist.

$ARGIS $USER11g| Undefined user macro detected, click to set a value..

Simply finish typing the name of the user Macro and as soon as you type the closing $ a blue $ button
will appear to the right.

When you hover your mouse over the blue S button a message window will appear informing you that
the macro is undefined and to click it to set a value.

Click the blue S button and the Create New User Macro window will appear.

You must restart Magios Core after creating a new macro for the value to be translated.

to the plugins

$=fusr/local/nagios/libexec

SUP3Rs3CR3

Type a value in the field at the bottom of the window and then click the Save Macro button.

You will receive a success message once the new macro has been added.
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Click the Close button when done

Note: The new macro will not be active until Nagios Core is restarted. This will occur when
you Apply Configuration OR you finish a Configuration Wizard.

The ability to add new user macros will be available if the User Macros component is enabled, see the
Configuring User Macros Component section for more information on this.

Special Characters

User macros are a great way to use complicated passwords with special characters in them. Special
characters are a group of characters that carry out special instructions, like the dollar sign $ which
does expansion in bash. If you tried to use a S in a password argument at the command line, you
would see it throw an unexpected error.

"I"

In Nagios Configurations an exclamation mark “!” Is used as an argument separator. If you used this
in a password, then the password will be split, and it will change the number of arguments being
presented to the monitoring engine.

The following KB article explains special characters in more detail and should be taken into
consideration with user macros:

Special Characters

Finishing Up

This completes the documentation on how to use the Nagios XI User Macros Component. If you have
additional questions or other support-related questions, please visit us at our Nagios Support Forum,
Nagios Knowledge Base, or Nagios Library:

Visit Nagios Support Forum Visit Nagios Knowledge Base Visit Nagios Library
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