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How To Use Dashboards In Nagios XI 2026 

Purpose 
This document describes how to create and manage custom Dashboards in Nagios XI 2026.  

Accessing Dashboards 
To begin, navigate to the Dashboards menu. The first thing you will see is the built-in localhost Smart 
Dashboard. You’ll also see pre-loaded Linux Servers and Websites dashboards. 

 

Smart vs. Legacy Dashboards 
To begin, a quick explanation of the two dashboard types: 

Smart Dashboards 

Introduced in Nagios XI 2026, Smart Dashboards provide a modern look and responsive React design, 
as well as a Smart Dashboard Wizard to help you automatically generate dashboards for individual 
hosts, groups, or Nagios XI system metrics.  

Legacy Dashboards 

Legacy dashboards are the traditional dashboards longtime users will be most familiar with. Although 
many Legacy dashlets have a Smart equivalent, some dashlets such as Metrics, Hostgroup Summary, 
Overview, and Grid, and Metrics are currently Legacy-only.  

Universal dashboard management options will be covered toward the end of this document.  
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Creating a New Smart Dashboard 

Smart Dashboard Wizard 

To automatically generate a new Smart dashboard, click Smart Dashboard Wizard in the Dashboard 
Tools section, then give it a Title, select the object or group you’d like to use as a data source in the 
Template dropdown. You can also choose whether to make it a personal dashboard visible only to 
your user, or a Global dashboard visible to all system users.  

 

Once you make your selections, click Submit, and a new dashboard will be created for you. Here’s an 
example that used the Specific Hostgroup template, showing a linux servers group: 
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Custom Smart Dashboard 

To create a custom Smart dashboard, click Add New Dashboard in the Dashboard Tools section. 
Enter a Title, select Smart, and choose whether to make the dashboard personal or Global (visible to 
all other XI system users).  

 

Click Submit, and your new dashboard will appear in the Smart Dashboards section.  

 

Click the title to be brought to your new blank dashboard so you can begin customizing it by adding 
dashlets.  
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Creating, Using, and Managing Smart Dashlets 

Adding Smart Dashlets  

To add a new dashlet, click + Add Dashlet at the top of the dashboard: 

 

 

Next, click the type of dashlet you’d like to use from the many available options.  

 

Note that the Custom dashlet type enables you to add custom 
dashlets you’ve created to your Smart dashboards. Any dashlets 
you’ve added in the Admin > System Extensions > Manage 
Dashlets menu will appear in the Dashlet dropdown in the setup 
window for the Custom type.  
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For this example, we’ll create a Graph dashlet. First, assign a Name for your dashlet, which will appear 
on it’s upper left to help you identify it. Next, choose the Host, Service, and Metric you’d like to create 
a graph dashlet of, such as Memory Usage on a Webserver over the last 24 hours. 

 

If you toggle Keep menu open on submit, the Add Dashlet dialog will remain open after creation, 
enabling you to immediately create another one.  

 

When finished, click Submit, and your new dashlet will appear on your dashboard.  
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Resizing and Moving Smart Dashlets 

To resize a Smart dashlet, click and hold on the bottom right corner, and drag it to the desired size.  

 

To move a dashlet, click and hold on the top title bar, and move it where you’d like it to go. Other 
dashlets will dynamically move to accommodate it’s new location, and can be re-arranged as you see 
fit once your re-located dashlet is in place.  

 

Editing, Cloning, and Deleting Smart Dashlets  

Click the Actions icon on the upper right of a dashlet to edit it’s settings, clone it, or delete it.  
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Refreshing and Adjusting the Auto Refesh Interval 

To refresh your dashboard so that it reflects the latest Nagios check data, click the Refresh icon. 

 

To adjust the Auto Refresh interval (default 5 minutes), click the down-arrow to the right of the 
Refresh icon, and select your desired rate.  

 

Renaming and Deleting Smart Dashboards 

To rename or delete and existing dashboard, click to Actions icon to the right of it’s name in the 
lefthand Smart Dashboards section of the Dashboards menu.  

 

Exporting and Importing Smart Dashboards 

Dashboards can be exported as a json file to be shared with other users. To export a dashboard, click 
the Export button, then select a filename and click Export.  
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To import a dashboard using a json file, click Import Smart Dashboard in the lefthand Dashboard 
Tools section, then select your file and click Import.  

 

 

Creating a New Legacy Dashboard 

Dashboard Wizard 

To automatically generate a new Legacy dashboard, click Dashboard Wizard in the Legacy Dashboard 
Tools section, then give it a Title, select the object or group you’d like to use as a data source in the 
Template dropdown. You can also choose whether to make it a personal dashboard visible only to 
your user, or a Global dashboard visible to all system users.  
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Once you make your selections, click Submit, and a new dashboard will be created for you. Here’s an 
example that used the Specific Hostgroup template, showing a linux servers group: 

 

Custom Legacy Dashboard 

To create a new Legacy dashboard, click the Add New Dashboard link under the Dashboard Tools, 
and select Legacy. Enter a title, choose either a Transparent background or a custom background 
color, then click Submit to create your dashboard.  
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Once the dashboard has been created it will now appear in the Legacy Dashboards section in the 
lefthand menu.  Clicking it will reveal an empty dashboard. 

 

 

Adding, Using, and Managing Legacy Dashlets 

Adding Legacy Dashlets 

A dashboard is simply an empty page until you add a dashlet to it.  Dashlets are nearly everywhere in 
the Nagios XI interface.  Wherever you are in the Nagios XI interface, when you see the icon, you 
can add that graphical element to any Legacy dashboard. 

1. Click the Available Dashlets link in the left pane under Legacy Dashboard Tools to view a list of 
available dashlets. 
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2. To add a dashlet to a dashboard, click the image for that dashlet.   
 

3. The Add to Dashboard window appears.  The dashlet being added in this example requires you 
to provide a Dashlet Title. 

4. You also need to select which dashboard you want to add the dashlet to. 

5. Click the Add It button to add the dashlet.   

 

6. After adding the dashlet, navigate to the dashboard you added it to (under Legacy 
Dashboards). 

Note that you can also right-click any empty space in a dashboard and select Add Dashlet to open the 
Available Dashlets menu and choose a new dashlet.  

Resizing and Moving Legacy Dashlets 

To resize a Legacy Dashlet, click-hold on the bottom right corner and drag it to your desired size.  

 

To move a dashlet, click-hold on it, then drag it to where you’d like it to go.  
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Legacy Dashlet Controls 

To access dashlet control options, either click the Actions icon if it is a small dashlet: 

 

 

…or hover over the dashlet to see icons for the available actions if the dashlet is large enough to show 
them: 
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Hide Title (eye icon) 

This enables you to hide the blue dashlet title: 

 

Pin (pin icon) 

This enables you to pin a dashlet in place, so that it cannot be moved, and won’t dynamicall arrange 
itself when other dashlets are moved, until un-pinned.  

 

Re-configure (gear icon) 

This option enables you to re-configure some basic settings of your dashlet, such as it’s Title. 

 

Hide Background (2 squares icon) 

This option can be used to make the dashlet background transparent. 

 

Delete (x icon) 

Use this option to permanently delete a dashlet from a dashboard.  
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Importing Legacy Dashlets 
If you’ve developed a new dashlet of your own, or would like to add a dashlet found somewhere like 
the Nagios Exchange community site, goto Legacy Dashboard Tools > Manage Dashlets and select 
your file. 

 
 
 
Downloading and Deleting Dashlets from the System 
To download a dashlet file, click the download icon on it’s upper right in Legacy Dashboard Tools > 
Manage Dashlets.  

 
 
To permanently delete a dashlet from the system, click the delete (trashcan) icon.  
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Managing Legacy Dashboards  

Legacy Dashboard Tools > Manage Dashboards Menu Options  

 
To clone a dashboard click the Clone icon. Select a Title for the new dashboard, then click Clone.  

 
 
To edit a dashboard Title and background options, click the Edit icon.  

 
 
To export a .txt file containing the dashboard settings that can be shared and imported, click the 
Export icon.  
 

 
 
To permanently delete a dashboard from the system, click the delete icon.  

 
 
To import a dashboard txt file that has been shared with you, click the blue Import button, then select 
your file.  
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In-Dashboard Menu Options 

You also can access various options by either right-clicking on any empty space in a dashboard, or by 
clicking the Actions icon on the upper right of a legacy dashboard.  

 

 
Export and Clone function as described above in the previous section.  
 
Arrange Dashlets will auto-arrange the dashlets on your dashboard.  
 
Show/Hide All Backgrounds will either show or hide the background on all dashlets on your 
dashboard.  
 
Dashboard Help will provide you with links to resources to help you manage Dashboards.  
 
Add to Favorites will add the dashboard to your menu Favorites.  
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Deploying Legacy Dashboards 

Nagios XI allows you to deploy your dashboards to other Nagios XI users.  Only a Nagios XI 
Administrator can deploy dashboards.  
 

This can be performed via Legacy Dashboard Tools > Deploy Dashboards. 

When using the Dashboard Deployment Tool there are several options available. 

 

1. Select which dashboards you want to deploy by checking the boxes in the Deploy column. 

2. You can change the name of the dashboard by updating the field in the Destination Name 
column. 

3. The Keep Synced option ensures that if a dashboard is updated, it will be updated to all the 
users it was deployed to. 

4. Select the users in the Deploy To Users list that you want to receive the dashboards chosen in 
the options above. 

5. Click the Deploy Dashboards button to deploy the dashboards to the users. 
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Note: It is worth mentioning that there is no central way to manage every user's dashboards 
on one screen. You can only manage Legacy dashboards for the user that you are currently 
logged in as, be they personal or deployed.   

If you plan on creating Legacy dashboards that you will be deploying to many users and updating 
these dashboards on a regular basis, it is recommended to create a dedicated Nagios XI user account 
for this specific purpose.  This allows you to centrally manage these dashboards and means you do 
not have any issues when a user is no longer granted access to Nagios XI (if a user left the company 
and their Nagios XI user account was deleted, their dashboards will be lost). 

Popout or Fullscreen a Smart or Legacy Dashboard  
Sometimes you do not need the Navigation pane or menu bar when viewing a dashboard.  There are 
two ways that you can achieve this functionality in both Smart and Legacy Dashboards.  

Popout 

On the far right of the top menu bar there is an icon with three vertical dots. When you hover over this 
icon a drop-down list of options appears. Click the Popout icon to open the current dashboard into a 
new tab / window. 

Fullscreen 

You can click the upward pointing arrow icon that appears in the upper left of a dashboard to expand 
it to fill the browser window. 

After clicking the arrow icon the dashboard will appear without any navigation pane or menu bar.  
There is now a downward pointing arrow icon in the upper left that will allow you to close the full 
screen mode to restore the navigation pane and menu bar. 
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Other Smart and Legacy Dashboard Options  
You will notice several other options available when you click the three vertical dots icon on the upper 
right.  

 

Schedule Page 

To schedule a dashboard for automatic delivery as  PDF, choose this option, then customize the 
various settings: 
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Add to My Views 

Choose this option to add a Dashboard to your Views rotation. Enter a View Title, then click Submit.  

Get Permalink 

Use this option to generate a URL that goes directly to the dashboard. 

Using Dashboards as Your Home Landing Page 
To learn more about how to make your Home page a custom dashboard, you can refer to this 
document: 

Customizing the Landing Page in Nagios XI 2026 

Finishing Up 
This completes the documentation on Using Dashboards in Nagios XI 2026. If you have additional 
questions or other support-related questions, please visit us at our Nagios Support Forum, Nagios 
Knowledge Base, or Nagios Library: 

Visit Nagios Support Forum Visit Nagios Knowledge Base Visit Nagios Library 

https://assets.nagios.com/downloads/nagiosxi/docs/Customizing-the-Landing-Page-in-Nagios-XI-2026.pdf
https://support.nagios.com/forum/
https://support.nagios.com/kb/
https://library.nagios.com/

